Invoice payments by card

Incident Report for Sproom

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 12:58 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 02, 2026 - 08:07 UTC

Investigating

We have found the reason why invoice payments by cards are failing. Our customers have no problems with their cards as it is our issue.
Posted Jul 02, 2026 - 08:07 UTC